Koha Test Wiki MW Canasta on Koha Portainer
Test major Koha Wiki changes or bug fixes here without fear of breaking the production wiki.
For the current Koha Wiki, visit https://wiki.koha-community.org .Acquisitions funds endpoint RFC
Jump to navigation
Jump to search
Actions and routes
Description | Action | Proposed path |
List funds | GET |
/acquisitions/funds |
Add a fund | POST |
/acquisitions/funds |
Get a fund | GET |
/acquisitions/funds/{fund_id} |
Overwrite a fund | PUT |
/acquisitions/funds/{fund_id} |
Delete a fund | DELETE |
/acquisitions/funds/{fund_id} |
Partially update a fund | PATCH |
/acquisitions/funds/{fund_id} |
Description | Action | Proposed path |
List fund users | GET |
/acquisitions/funds/{fund_id}/patrons |
Add a fund user | POST |
/acquisitions/funds/{fund_id}/patrons |
Delete a fund user | DELETE |
/acquisitions/funds/{fund_id}/patrons/{patron_id} |
Note: it would be correct to pick users over patrons in this case. This should be voted, though.
Fund object definition
DB schema | API | Comments |
budget_id | fund_id | Name changed to match UI |
budget_code | code | |
budget_name | name | |
budget_branchcode | library_id | |
budget_amount | total_amount | |
budget_encumb | warn_at_percentage | |
budget_expend | warn_at_amount | |
budget_notes | notes | |
budget_period_id | budget_id | |
timestamp | timestamp | |
budget_owner_id | fund_owner_id | |
budget_permission | fund_access | |
sort1_authcat | statistic1_auth_value_category | |
sort2_authcat | statistic2_auth_value_category |
Comments
- (fixed) What's budget in the code is fund in the GUI, which is quite confusing as is. We need to be careful to get it right for the API.
- (fixed) What's the reason to remove encumb and expend?
- fund_access: 1=owner, owner and users = 3, owner, users, and library = 2. How to translate this best into the API? Use words instead of magic numbers?
- statistics*_auth... also appears in the orders endpoint. We need to make them consistent.
--Kfischer 16:39, 10 April 2018 (EDT)